Author Topic: Source code access.  (Read 15977 times)

Offline Taimon

  • Planewalker
  • *****
  • Posts: 326
Re: Source code access.
« Reply #25 on: July 16, 2009, 04:13:40 AM »
When I set it up I told it to use unix style line endings, it seemed the least confusing of all the options.
I suggest you disable autocrlf  in the config (should be in "%GIT_DIR%/etc/gitconfig"). If you use an editor that keeps line endings as they are, you should be fine.

Offline plainab

  • Sasha al'Therin
  • Planewalker
  • *****
  • Posts: 491
    • Infinity Engine Modding
Re: Source code access.
« Reply #26 on: July 16, 2009, 07:51:20 PM »
When I set it up I told it to use unix style line endings, it seemed the least confusing of all the options.
I suggest you disable autocrlf  in the config (should be in "%GIT_DIR%/etc/gitconfig"). If you use an editor that keeps line endings as they are, you should be fine.
The first time I had just used the github website and that is probably what brought up the crlf issue.  Now that I've got a local copy, I plan on using ConTEXT do any edits/additions. I would think that it leaves the line endings as they are, but I don't really know...

I found the gifconfig file. Took a wild guess and forced it to open with ConTEXT (no extension so Windows won't automatically let me open it).  It's a basic text file, and the autoCRLF is set to input.  Do I just replace 'input' with 'disable' or is there something else that I should enter?  I'd rather get it done right, than do something wrong and screw things up later...

My working mods:
an AI Party Script for BG2 game engine DOWNLOAD LINK ONLY!
Interactive Tweaks for BG series with some IWD support. DOWNLOAD LINK ONLY!
Rest For 8 Hours an IWD mod
-------------------------------------------
My contributions: BG1Fixpack, BG1Tweaks
On Hold: Solestia an NPC for SOA
-------------------------------------------
My website: http://sasha-altherin.webs.com

Offline Taimon

  • Planewalker
  • *****
  • Posts: 326
Re: Source code access.
« Reply #27 on: July 17, 2009, 01:11:36 AM »
Do I just replace 'input' with 'disable' or is there something else that I should enter?  I'd rather get it done right, than do something wrong and screw things up later...
Either delete the autocrlf line or set it to false.
You can see the effect of autocrlf if you do a fresh checkout and a `git diff' shows you that all files are modified.

 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?: