Author Topic: IEEP doesn't work -- so what can I use?  (Read 3288 times)

Guest Man

  • Guest
IEEP doesn't work -- so what can I use?
« on: November 07, 2008, 01:19:59 PM »
I have a new Vista laptop with the first Baldur's Gate installed on it (and, as I mentioned in another thread, I also have SoA+ToB on a flash drive).  I basically want an item maker, and for years, IEEP was my go-to tool.  But when attemptin' to use it on the Vista system...

Run-Time error '399':

Component 'RICHTX32.OCX' or one of its dependancies not currently registered: a file is missing or invalid"



Now, I've read that IEEP is, for the most part, an outdated tool.  Makes sense, since the last time I used the program was on a Win98 computer.  But now, if IEEP won't work, what can I use for an item editor?  I did a PocketPlane forums search to locate the tool thread, and apparently there was some new TeamBG tool that replaced IEEP, but...the link is dead, and the thread housing it was made in 2004.  Naturally, this has me at somethin' of a loss...

Are there any good item makers/importers that could work well with Vista?

Offline GeN1e

  • Planewalker
  • *****
  • Posts: 267
  • Gender: Male
Re: IEEP doesn't work -- so what can I use?
« Reply #1 on: November 07, 2008, 02:32:12 PM »
Quote
Component 'RICHTX32.OCX' or one of its dependancies not currently registered: a file is missing or invalid"
Google is your friend. Download it and register.

Of other editors there are DLTCEP and NearInfinity.

Guest Man

  • Guest
Re: IEEP doesn't work -- so what can I use?
« Reply #2 on: November 07, 2008, 08:00:48 PM »
What little I've seen from my Google search makes me extremely leery of downloading such a thing, especially since it seems to be a system file. 

DLTCEP, I think, was the other editor mentioned in the 2004 thread, but it linked to teambg; the link be dead.  On a more important note, what of those two editors?  Where can they be found, will they work with Vista, will I need to download additional components, will either one mess with my system, etc...

As you can see, I'm paranoid about that sort of thing.

Offline plainab

  • Sasha al'Therin
  • Planewalker
  • *****
  • Posts: 491
    • Infinity Engine Modding
Re: IEEP doesn't work -- so what can I use?
« Reply #3 on: November 07, 2008, 10:48:38 PM »
You can find a download link in this thread/post relating to DLTCEP
http://forums.gibberlings3.net/index.php?showtopic=11824&view=findpost&p=100771

You can get the latest version of Near Infinity here.
http://sourceforge.net/projects/nearinfinity/
If I understand correctly, Near Infinity does not work beyond a certain level of java. (Yes, Java is required.) But I don't know if that is for the beta or for the older version. Don't let the term beta make you think it is not stable. It is only beta because it has been updated and given more functionality by someone other than the original maker.
My working mods:
an AI Party Script for BG2 game engine DOWNLOAD LINK ONLY!
Interactive Tweaks for BG series with some IWD support. DOWNLOAD LINK ONLY!
Rest For 8 Hours an IWD mod
-------------------------------------------
My contributions: BG1Fixpack, BG1Tweaks
On Hold: Solestia an NPC for SOA
-------------------------------------------
My website: http://sasha-altherin.webs.com

Offline Mike1072

  • Planewalker
  • *****
  • Posts: 296
  • Gender: Male
Re: IEEP doesn't work -- so what can I use?
« Reply #4 on: November 08, 2008, 04:15:09 AM »
You can get the latest version of Near Infinity here.
http://sourceforge.net/projects/nearinfinity/
If I understand correctly, Near Infinity does not work beyond a certain level of java. (Yes, Java is required.) But I don't know if that is for the beta or for the older version. Don't let the term beta make you think it is not stable. It is only beta because it has been updated and given more functionality by someone other than the original maker.
Do you mean NI refusing to work on newer versions of Java?  If you're referring to this, it worked fine for me then and is still working well.  I just installed Java 6 Update 10 to test, and everything's looking like it should.

Offline plainab

  • Sasha al'Therin
  • Planewalker
  • *****
  • Posts: 491
    • Infinity Engine Modding
Re: IEEP doesn't work -- so what can I use?
« Reply #5 on: November 08, 2008, 08:26:09 AM »
You can get the latest version of Near Infinity here.
http://sourceforge.net/projects/nearinfinity/
If I understand correctly, Near Infinity does not work beyond a certain level of java. (Yes, Java is required.) But I don't know if that is for the beta or for the older version. Don't let the term beta make you think it is not stable. It is only beta because it has been updated and given more functionality by someone other than the original maker.
Do you mean NI refusing to work on newer versions of Java?  If you're referring to this, it worked fine for me then and is still working well.  I just installed Java 6 Update 10 to test, and everything's looking like it should.
Okay, so apparently I got confused the first time around when I had read about it.
NI requires Java 1.5 or greater.
My working mods:
an AI Party Script for BG2 game engine DOWNLOAD LINK ONLY!
Interactive Tweaks for BG series with some IWD support. DOWNLOAD LINK ONLY!
Rest For 8 Hours an IWD mod
-------------------------------------------
My contributions: BG1Fixpack, BG1Tweaks
On Hold: Solestia an NPC for SOA
-------------------------------------------
My website: http://sasha-altherin.webs.com

Offline CoM_Solaufein

  • CoM Founder
  • Planewalker
  • *****
  • Posts: 184
  • Gender: Male
  • War is Peace, Freedom is Slavery, Ignorance is Strength
    • Chosen of Mystra
Re: IEEP doesn't work -- so what can I use?
« Reply #6 on: November 14, 2008, 07:45:54 AM »
I have a new Vista laptop with the first Baldur's Gate installed on it (and, as I mentioned in another thread, I also have SoA+ToB on a flash drive).  I basically want an item maker, and for years, IEEP was my go-to tool.  But when attemptin' to use it on the Vista system...

Run-Time error '399':

Component 'RICHTX32.OCX' or one of its dependancies not currently registered: a file is missing or invalid"



Now, I've read that IEEP is, for the most part, an outdated tool.  Makes sense, since the last time I used the program was on a Win98 computer.  But now, if IEEP won't work, what can I use for an item editor?  I did a PocketPlane forums search to locate the tool thread, and apparently there was some new TeamBG tool that replaced IEEP, but...the link is dead, and the thread housing it was made in 2004.  Naturally, this has me at somethin' of a loss...

Are there any good item makers/importers that could work well with Vista?


You need to install or reinstall the VB6 package. Most of the old TeamBG tools use Visual Basic as the programming language for their tools.

 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?: