Author Topic: Assertion Error with Underrepresented Items -- seanas  (Read 7873 times)

Offline jcompton

  • Niche Exploiter
  • Administrator
  • Planewalker
  • *****
  • Posts: 7244
Assertion Error with Underrepresented Items -- seanas
« on: May 20, 2004, 11:38:10 PM »
seanas     
Posted: May 20 2004, 12:39 PM


[this has been posted previously at: http://www.teambg.net/forum/?showtopic=13635]

i've been having trouble with the assertion error:

An Assertion failed in ChVidImage.cpp at line number 1921 Programmer says: .BAM is corrupted (GetFrame() failed)

during a game of Big Picture i'm currently running (more background can be found in the link to the teambg forum above).

through a process of re-installation and elimination, it seems to be caused by Caballus' Whispering Staff (U#HFSFWS).

i'm not sure whether trolls in Big Picture don't like being silenced, or whether the mass invisibility power of the staff is bugged (and whether it's bugged only in BP or in general), but at any rate unequipping it is the only thing that prevents the assertion error, so i'm guessing Caballus' Staff + BP = Assertion Error.

whether this is a fault caused by the staff or BP i don't know, but i'm posting the bug report here as well just in case.

(luckily, i've had no problems with the Charged Short Sword of Wounding, Flaming Burst Mace of Disruption, or Holy Swizarnian Hammer of Lucerne )

cheers,

sean
Cespenar says, "Kelsey and friends be at the Pocket Plane? Ohhh yesssss!" http://www.pocketplane.net

Grocer

  • Guest
Re: Assertion Error with Underrepresented Items -- seanas
« Reply #1 on: February 19, 2007, 11:35:35 AM »
Sorry to bump such an old post, but it didn't have a response and I'm having the exact same issue as the OP.  I don't have Big Picture installed, and the error shows up any time an attack is attempted with Caballus' Whispering Staff.  It can be equiped with no problems, and it's abilities used, but not attacked with.

Is there anything I can do to fix this behavior?  I can play around it of course, but it's frustrating.

On a related note, I'm also having an issue with the Breach ability of Twelve Paces not actually working.  It gets cast, but has no effect.  Not a big deal, but if anyone has any ideas...

thanks,
grocer

Offline Peremptor

  • Planewalker
  • *****
  • Posts: 3
  • Gender: Male
Re: Assertion Error with Underrepresented Items -- seanas
« Reply #2 on: April 10, 2007, 12:36:04 PM »
I had this same problem with the staff and didn't really catch it until I reached a battle where Jaheira's AI would always make her go for her melee weapon (using her primarily with a ranged weapon) and I couldn't advance due to the assertion error. Seems like the main source of the problem is the fact that its a one handed staff weapon and this is incompatible with the two handed animation of the regular staff animation (maybe, just a guess based on what I did to solve the issue).

I was able to fix it with Near Infinity by searching and comparing the other 1 handed staff weapon in the game I know about, the Staff Mace (STAF06.ITM) and trying to figure out how to edit U#HFSWS.ITM so it uses the same mace attack animation which worked for me without any further incidents. All I had to do was delete the 'extra' set item color "Global Effect" that the Whispering Staff had compared to the Staff Mace and that seems to have solved the assertion error and it now looks like a mace when equipped. I really have no idea why it worked though :).

 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?: