Author Topic: Ambients - weird behavior  (Read 1376 times)

Offline Lu

  • Planewalker
  • *****
  • Posts: 750
  • Gender: Female
Ambients - weird behavior
« on: April 18, 2006, 02:34:01 PM »
  A problem with a custom area in a mod we're working on. Testing goes smoothly, but then we add a couple ambients (four), and when I console Charname into the area, the game crashes. However, unbiffing ambients' wav files into Override solves the problem, testing goes smoothly again. WTF? I mean, any ideas?
  Specifically, the wavs are... never mind, my partner says it's the same with any wav files

Offline Meira

  • Planewalker
  • *****
  • Posts: 188
  • Gender: Female
  • I'm the snow on your lips
    • Amber's Home
Re: Ambients - weird behavior
« Reply #1 on: April 18, 2006, 02:50:53 PM »
Ambients have to be in the same biff as your area or in the override with the said area. Otherwise they crass your game (as you already noticed). I have no idea why, though. When you're making a mod and use game's original ambients you can copy the wavs to override in your tp2.  For example:

COPY_EXISTING ~ams602j1.wav~    ~override/ams602j1.wav~   // in AREA060A.BIF

 Depending what waws you use, you might have to ask the player to make full install or provide the correct CD in the CD drive. WeiDU (at least used) to give so pretty non-helpful error messages if it cant find the file you're copying.

Offline Avenger_teambg

  • Planewalker
  • *****
  • Posts: 399
Re: Ambients - weird behavior
« Reply #2 on: April 19, 2006, 02:07:32 AM »
This is a very old and known problem. It should be part of the modder bug faq.

Offline Lu

  • Planewalker
  • *****
  • Posts: 750
  • Gender: Female
Re: Ambients - weird behavior
« Reply #3 on: April 19, 2006, 12:27:33 PM »
 Definitely looks like a IE bug. I mean, when wavs are referenced in Dialog.tlk, or say, in .CRE files, the fact that a wav file is missing doesn't affect the game at all (other that you don't hear sounds, of course). So by default one would expect the same IE behavior in the situation we are discussing here, sure enough
 Thanks, guys

Offline SimDing0™

  • Back In Black
  • Global Moderator
  • Planewalker
  • *****
  • Posts: 3496
  • Gender: Male
  • Word Enhancer
Re: Ambients - weird behavior
« Reply #4 on: April 19, 2006, 12:32:53 PM »
I always figured it's more likely to be something to do with the cacheing of files than a bug.

Offline Lu

  • Planewalker
  • *****
  • Posts: 750
  • Gender: Female
Re: Ambients - weird behavior
« Reply #5 on: April 20, 2006, 01:37:10 PM »
So I need to have an .ARE file and referenced wavs biffed together, while the same area WED, TIS and the rest can be biffed separately, right? Just to make sure that I understand it correctly

Offline Lu

  • Planewalker
  • *****
  • Posts: 750
  • Gender: Female
Re: Ambients - weird behavior
« Reply #6 on: August 08, 2006, 09:52:11 PM »
   Eventually, it seems to me that those ambients that are stored in AMBSound.biff can be left there safely, the others have to be extracted into override

 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?: