Author Topic: Problem installing v15  (Read 4994 times)

Offline GetCool

  • Planewalker
  • *****
  • Posts: 10
Problem installing v15
« on: October 01, 2004, 02:39:12 AM »
I'm getting "parse errors" when I try to install v15.  This doesn't seem to be related to the Unfinished Business problem with v14, even though I do have Unfinished Business installed.  I've copied the errors as they appear in the command prompt window during installation below.  Also, a copy of my SETUP-VIRTUE.DEBUG.txt is here, and a copy of my WeiDU.log is here.

I always install Virtue last in my mod installation order, and I've had v13 installed in the past with this exact same configuration of mods and haven't had a problem.  I'm going to go back to v13 for now.

EDIT: By the way, I forgot to say thank you for this mod.  I didn't mean for my first post here to sound like such a complaint.  This is a great mod and I will always use it when I play BG2.

Code: [Select]
[BALDUR.BCS.BAF] PARSE ERROR at line 2977 column 23-31
Near Text: BARBARIAN
        syntax error

[BALDUR.BCS.BAF]  ERROR at line 2977 column 23-31
Near Text: BARBARIAN
        Parsing.Parse_error
ERROR: parsing [BALDUR.BCS.BAF]: Parsing.Parse_error

[BALDUR25.BCS.BAF] PARSE ERROR at line 1849 column 23-31
Near Text: BARBARIAN
        syntax error

[BALDUR25.BCS.BAF]  ERROR at line 1849 column 23-31
Near Text: BARBARIAN
        Parsing.Parse_error
ERROR: parsing [BALDUR25.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x12

[RDOG.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RDOG.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RDOG.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x12

[RDWARF.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RDWARF.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RDWARF.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x27

[RETTER.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RETTER.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RETTER.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x12

[RGIBBLER.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RGIBBLER.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RGIBBLER.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x12

[RHALFLIN.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RHALFLIN.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RHALFLIN.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x27

[RHOBGOBA.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RHOBGOBA.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RHOBGOBA.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x27

[RHOBGOBF.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RHOBGOBF.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RHOBGOBF.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x12

[RKOBOLD.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RKOBOLD.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RKOBOLD.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x12

[ROGRE.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[ROGRE.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [ROGRE.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x27

[RSIREN.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RSIREN.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RSIREN.BCS.BAF]: Parsing.Parse_error
Cannot resolve trigger 0x12

[RSIRINE.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
        syntax error

[RSIRINE.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
        Parsing.Parse_error
ERROR: parsing [RSIRINE.BCS.BAF]: Parsing.Parse_error
Extending game scripts ...

[BALDUR.BCS] LEXER ERROR at line 1 column 0-1
Near Text: IF
        invalid keyword [IF]

[BALDUR.BCS]  ERROR at line 1 column 0-1
Near Text: IF
        Parsing.Parse_error
ERROR: parsing [BALDUR.BCS]: Parsing.Parse_error

ERROR Installing [Virtue], rolling back to previous state
Will uninstall 294 files for [SETUP-VIRTUE.TP2] component 0.
Uninstalled    294 files for [SETUP-VIRTUE.TP2] component 0.
ERROR: Parsing.Parse_error
PLEASE email the file SETUP-VIRTUE.DEBUG to SimDing0@hotmail.com
Using Language [English]
« Last Edit: October 01, 2004, 02:46:33 AM by GetCool »

Offline SimDing0™

  • Back In Black
  • Global Moderator
  • Planewalker
  • *****
  • Posts: 3496
  • Gender: Male
  • Word Enhancer
Re: Problem installing v15
« Reply #1 on: October 02, 2004, 04:53:57 AM »
In spite of how horrific it might look, there are actually only 1 or 2 problems in there. If you know how, could you e-mail me your baldur.bcs and baldur25.bcs files (SimDing0@pocketplane.net)? Otherwise, I'll see what I can do based on the log files.

Offline GetCool

  • Planewalker
  • *****
  • Posts: 10
Re: Problem installing v15
« Reply #2 on: October 02, 2004, 05:08:34 PM »
I just sent you an e-mail with the files.

In spite of how horrific it might look, there are actually only 1 or 2 problems in there. If you know how, could you e-mail me your baldur.bcs and baldur25.bcs files (SimDing0@pocketplane.net)? Otherwise, I'll see what I can do based on the log files.

Offline Littiz

  • Planewalker
  • *****
  • Posts: 23
Re: Problem installing v15
« Reply #3 on: October 05, 2004, 02:03:46 PM »
Happened to me as well (don't remember the details)
I've not been able to install the last two versions of Virtue, in fact :(

If you need, I can check again (playing TuTu ATM)

Offline Burning Daylight

  • Planewalker
  • *****
  • Posts: 2
Re: Problem installing v15
« Reply #4 on: October 07, 2004, 11:21:07 AM »
-i have also some problems to install virtue 1.5
Quote
ERROR locating resource:
Resource [CM7000.BCS] not found in KEY file:
   [./chitin.key]

ERROR Installing [Vertu], rolling back to previous state
[virtue/backup/0/UNSETSTR.0] loaded, 58 bytes
Un-SET_STRING #9465 from ~Vertu : <VDESC>...~ back to ~Rιputation~
[virtue/backup/0/UNINSTALL.0] loaded, 5024 bytes
Will uninstall 245 files for [SETUP-VIRTUE.TP2] component 0.
  Restoring backed-up [virtue/backup/0/ACTION.IDS]
i can't install virtue cause of theses ligns
my mods: ( in this order )
munchmod
ajocmod
browndragon
azenmod
dos
battles
tactics
super frikkraag
improved asylum
improved oasis
solaufein
planar sphere
planar sphere return
tbpack
apack
ascension
virtue thus...

( no problem with the 1.3 version )
how can i correct the problem ?
thanks for your advices...


« Last Edit: October 07, 2004, 11:35:40 AM by Burning Daylight »

Offline SimDing0™

  • Back In Black
  • Global Moderator
  • Planewalker
  • *****
  • Posts: 3496
  • Gender: Male
  • Word Enhancer
Re: Problem installing v15
« Reply #5 on: October 15, 2004, 08:00:44 AM »
Okay, the CM7000 problem is a separate issue; I'll look into that in a sec.

The problem in the first post which is causing Virtue not to install appears to be an error in the Refinements installer, rather than a Virtue issue. Refinements modified kit.ids, among other things adding:

0X401F BARBARIAN

The "X" in this is uppercase where it should be lower, which I suspect is causing WeiDU to choke. The correct entry should be:

0x401F BARBARIAN

Could someone else make this change in their IDS file and confirm that it allows Virtue to install successfully? If so, someone needs to tell Littiz so he can correct the Refinements installer.

Offline Littiz

  • Planewalker
  • *****
  • Posts: 23
Re: Problem installing v15
« Reply #6 on: October 16, 2004, 07:05:17 AM »
*covers his head with ash*

Ehm, thx Sim, I've just fixed for Version 2 :)
Anyway, I clearly remember I tried to install Virtue 15 before Refinements, so I must have been a victim of the other reported problem..

Offline JW

  • Planewalker
  • *****
  • Posts: 68
Re: Problem installing v15
« Reply #7 on: October 16, 2004, 09:01:36 AM »
What part of refinements modify kit.ids?
I have refinements v.1.05 installed with all its components but Swashimoen and SwordAngel kit, and my only Barbarian reference inside KIT.IDS is: 0x00004000 BARBARIAN

I'm also 100% sure I installed Virtue v.14 AFTER refinements without problems (well, at least without errors on installation).

Offline SimDing0™

  • Back In Black
  • Global Moderator
  • Planewalker
  • *****
  • Posts: 3496
  • Gender: Male
  • Word Enhancer
Re: Problem installing v15
« Reply #8 on: October 16, 2004, 10:07:08 AM »
The Revised High Level Abilities is the component that alters the IDS, I think. It'll also only show up with Virtue v15, because prior to that I wasn't using some of the new WeIDU script handling commands.

Littiz, thanks for the fix (hopefully it actually remedies the issue, and I haven't made a total mistake). Out of interest, do you remember what other mods you had installed when you encountered the error with Virtue? I'm trying to track down exactly what mod introduces this CM7000.BCS.

Offline Burning Daylight

  • Planewalker
  • *****
  • Posts: 2
Re: Problem installing v15
« Reply #9 on: October 16, 2004, 03:20:28 PM »
I verified with NI i have in the override: many files : CM7000.are, CM7000.mos, CM7000.bmp, CM7000.tis, CM7000.bcs, CM700.wed

CM7000 seems to correspond with the mod Desecration of Souls Version 2. ( i recognised the CM7000.bmp )
In addition, the file CM7000.bcs is totally empty ( nothing in script or script source (decompiled) ) ???

edit
cm7000 are the files who add a new inn, in the slum district ( south of the nothern exit)
« Last Edit: October 16, 2004, 03:22:47 PM by Burning Daylight »

Offline GetCool

  • Planewalker
  • *****
  • Posts: 10
Re: Problem installing v15
« Reply #10 on: October 17, 2004, 01:00:13 AM »
Thanks for the reply and the investigation.  I tried making this change to my kit.ids, but it still doesn't seem to be working.  After doing that, I now get different errors, and even with these new errors it claims to have installed the mod successfully.  See here.

Unless I'm doing something wrong... I just opened up the kit.ids file in the override directory and changed "0X401F" to "0x401F".  Let me know if I'm missing something.  Also, let me know if you want any of my log files, etc. again.

Otherwise, thanks for looking into it and getting back to me.  And thank you, Littiz for making that correction in Refinements.

Okay, the CM7000 problem is a separate issue; I'll look into that in a sec.

The problem in the first post which is causing Virtue not to install appears to be an error in the Refinements installer, rather than a Virtue issue. Refinements modified kit.ids, among other things adding:

0X401F BARBARIAN

The "X" in this is uppercase where it should be lower, which I suspect is causing WeiDU to choke. The correct entry should be:

0x401F BARBARIAN

Could someone else make this change in their IDS file and confirm that it allows Virtue to install successfully? If so, someone needs to tell Littiz so he can correct the Refinements installer.
« Last Edit: October 17, 2004, 01:02:05 AM by GetCool »

Offline Littiz

  • Planewalker
  • *****
  • Posts: 23
Re: Problem installing v15
« Reply #11 on: October 17, 2004, 03:30:35 AM »
@GetCool: you're welcome, it's our "job" ;) Unfortunately this and all the other fixes/additions will be only in the next version I fear.

@Sim:
Got it, the problem is in the section where you decompile and re-compile all the scripts (! :o :o :o !).
I get many PARSE ERRORS...

Anyway, something tells me these might be unused files inherited from BG1........ ;)




[RDOG.BCS.BCS] parsed
Cannot resolve trigger 0x12

[RDOG.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RDOG.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error

...


[RDWARF.BCS.BCS] parsed
Cannot resolve trigger 0x12

[RDWARF.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RDWARF.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RDWARF.BCS.BAF]: Parsing.Parse_error
...


[RETTER.BCS.BCS] parsed
Cannot resolve trigger 0x27

[RETTER.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RETTER.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RETTER.BCS.BAF]: Parsing.Parse_error

...


[RGIBBLER.BCS.BCS] parsed
Cannot resolve trigger 0x12

[RGIBBLER.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RGIBBLER.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RGIBBLER.BCS.BAF]: Parsing.Parse_error
...


[RHALFLIN.BCS.BCS] parsed
Cannot resolve trigger 0x12

[RHALFLIN.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RHALFLIN.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RHALFLIN.BCS.BAF]: Parsing.Parse_error
...


[RHOBGOBA.BCS.BCS] parsed
Cannot resolve trigger 0x27

[RHOBGOBA.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RHOBGOBA.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RHOBGOBA.BCS.BAF]: Parsing.Parse_error
...


[RHOBGOBF.BCS.BCS] parsed
Cannot resolve trigger 0x27

[RHOBGOBF.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RHOBGOBF.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RHOBGOBF.BCS.BAF]: Parsing.Parse_error
...

[RKOBOLD.BCS.BCS] parsed
Cannot resolve trigger 0x12

[RKOBOLD.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RKOBOLD.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RKOBOLD.BCS.BAF]: Parsing.Parse_error
...

[ROGRE.BCS.BCS] parsed
Cannot resolve trigger 0x12

[ROGRE.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[ROGRE.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [ROGRE.BCS.BAF]: Parsing.Parse_error
...


[RSIREN.BCS.BCS] parsed
Cannot resolve trigger 0x27

[RSIREN.BCS.BAF] PARSE ERROR at line 1 column 0-1
Near Text: SC
   syntax error

[RSIREN.BCS.BAF]  ERROR at line 1 column 0-1
Near Text: SC
   Parsing.Parse_error
ERROR: parsing [RSIREN.BCS.BAF]: Parsing.Parse_error

....
« Last Edit: October 17, 2004, 03:33:35 AM by Littiz »

Offline SimDing0™

  • Back In Black
  • Global Moderator
  • Planewalker
  • *****
  • Posts: 3496
  • Gender: Male
  • Word Enhancer
Re: Problem installing v15
« Reply #12 on: October 17, 2004, 04:44:18 AM »
The parse errors can safely be ignored; they won't appear in the next version anyway, but it's just some messed up Bioware scripts that WeiDU has a problem with. The game will run fine.

Next version of Virtue should also not choke on CM7000.BCS.

Offline Caedwyr

  • Planewalker
  • *****
  • Posts: 433
Re: Problem installing v15
« Reply #13 on: October 19, 2004, 11:52:02 PM »
I can confirm that you still get the parsing errors, but Virtue 15 installs nicely if you make the change to kit.ids (capitalization)
"Knowledge is Power.  Power Corrupts.  Study Hard.  Be Evil."  - Mikka

PnP Celestials
Geomantic Sorcerer Kit

Offline jester

  • Here be dragons...
  • Planewalker
  • *****
  • Posts: 2416
  • If you fail, fail gloriously.
Re: Problem installing v15
« Reply #14 on: October 20, 2004, 10:20:15 AM »
Is this change of kit.ids explained in the readme or is it SEKRIT?
People should not be afraid of their governments. Governments should be afraid of their people.

Why spend all your day surfing for porn?




Balance in all things
I haven't had this much fun since... the last time.

Offline Caedwyr

  • Planewalker
  • *****
  • Posts: 433
Re: Problem installing v15
« Reply #15 on: October 20, 2004, 11:20:30 AM »
Nope, just in this thread.  Its a bug introduced by version 1.5 of Refinements.  Littiz has said it should be corrected in the next version of Refinements.
"Knowledge is Power.  Power Corrupts.  Study Hard.  Be Evil."  - Mikka

PnP Celestials
Geomantic Sorcerer Kit

Edar Macilrille

  • Guest
Re: Problem installing v15
« Reply #16 on: November 30, 2004, 09:30:36 AM »
First thanks to SimDing for what looks like a fine mod and just what I have wanted for awhile. Also for being one of the most responsive modders I have come across.
However, and secondly, I have trouble with parsing errors as well.


[virtue/scripts/oversight/bal_old.baf] PARSE ERROR at line 9 column 38-40
Near Text: @19
        unable to resolve translation string @19

[virtue/scripts/oversight/bal_old.baf]  ERROR at line 9 column 38-40
Near Text: @19
        Parsing.Parse_error
ERROR: parsing [virtue/scripts/oversight/bal_old.baf]: Parsing.Parse_error
ERROR: error compiling [virtue/scripts/oversight/bal_old.baf]: Parsing.Parse_err
or
ERROR: [BALDUR.BCS] -> [override] Patching Failed (COPY) (Parsing.Parse_error)

ERROR Installing [Virtue], rolling back to previous state
Will uninstall 241 files for [SETUP-VIRTUE.TP2] component 0.
Uninstalled    241 files for [SETUP-VIRTUE.TP2] component 0.
ERROR: Parsing.Parse_error
PLEASE email the file SETUP-VIRTUE.DEBUG to SimDing0@hotmail.com
Using Language [English]


It seems to clash with "Oversight"??
My installed mods are:
Ascension
Item Upgrade
Ease of Use
Oversight
Ashes of Embers
House of Sim

-here I would install Virtue if I could-

Before continuing with

Kelsey
Unfinished business
BG2 Refinements
Tactics
Flirtpacks
Rogue Rebalance
Clerical Remix
Cal-culator
G3 tweakpack
G3 anniversary pack
Subraces
Bag Bonus
Underrepresented Items
Solaufein

Will any of the latter clash with Virtue? I intend to just continue installing and add virtue at the end when Simding0 tells me what to do in order to make it work (tosses the friendly Ding0 a bone;-)  ).

Best wishes; Palle

Offline SimDing0™

  • Back In Black
  • Global Moderator
  • Planewalker
  • *****
  • Posts: 3496
  • Gender: Male
  • Word Enhancer
Re: Problem installing v15
« Reply #17 on: November 30, 2004, 09:43:09 AM »
None of the mods you mention should cause problems with Virtue. Are you sure you're using the latest version (v15)? Because I thought I'd fixed the issue with Oversight.

Edar Macilrille

  • Guest
Re: Problem installing v15
« Reply #18 on: December 03, 2004, 04:18:22 AM »
Hi Sim, I most certainly am.
I formatted my computer not a week ago and has started over with downloading everything in its newest version.

Should I send you the debug file (provided that I can find it)?

Best wishes; Palle

Offline SimDing0™

  • Back In Black
  • Global Moderator
  • Planewalker
  • *****
  • Posts: 3496
  • Gender: Male
  • Word Enhancer
Re: Problem installing v15
« Reply #19 on: December 10, 2004, 09:57:00 AM »
Okay, v16 should fix a number of install issues, including the one with Refinements. Everyone, please let me know if problems persist.

 

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Name: Email:
Verification:
Type the letters shown in the picture
Listen to the letters / Request another image
Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?: