Pocket Plane Group

Miscellany, Inc. => BG/PST/IWD Gameplay => Topic started by: Nesquaam on April 14, 2004, 09:17:32 AM

Title: Baldur's Gate II Install Problems
Post by: Nesquaam on April 14, 2004, 09:17:32 AM
I have a nasty little question. Here it comes:

When I try to install BGII, the setup ask for a fifth disc (which doens't exist when installing SoA only).
So I had to shut down the setup-process. But when I just started he setup again. the game could be installed again and instead of the "Install" button the "Play" button apeared.
There was no possibility to delete it from the software-list in the Config-screen (don't kown the English term). And there where no keys in the register.

Has anyone an idea what to do, or how this comes ?

Edit: Locked the topic, read the last post
Title: Re: Baldur's Gate II Install Problems
Post by: jcompton on April 14, 2004, 09:34:45 AM
Check the bioware.com technical support site, I believe they address this issue.
Title: Re: Baldur's Gate II Install Problems
Post by: Nesquaam on April 14, 2004, 09:37:27 AM
Thanks. That's all I have to say.
Title: Re: Baldur's Gate II Install Problems
Post by: Shodan on April 14, 2004, 10:47:39 AM
The "Insert Disc 5" problem occurs when the installer has had trouble reading one of the files on a previous CD, and so assumes there must be another disk with the relevant file on it. There are a number of steps you can take which may fix this problem and allow you to install properly, as outlined in the quote below.

These steps also apply to other installation errors such as the "Cyclic Redudancy Check" (CRC) error.
Quote:
1. When changing CDs during the installation, let the drive spin-up and then stop. Then click OK and see if the installer recognizes the disc change. Do this for all the CDs that are requested.

2.Try checking for a firmware/BIOS update for your CD or DVD drive. We have had several reports of sucessfull installs of the game once a firmware update was applied. You will have to check with your CD/DVD drive manufacturer for this kind of update.

3. If for whatever reason you are unable to do a Recommended or Full install, but you can do a Minimum install, please read How to "fake" a larger install from a Minimum.

4. If you have multiple CD/DVD drives, only install from one and do not try to use all of your drives. For some reason, this is confusing InstallShield.

5. If you cannot do any install without getting some sort of error or crash and you have about 5 Gig of free hard drive space, you can try to copy all 4 CDs to your hard drive, then run the install from there. Please note, you must copy all 4 CDs to the same directory for the install to run. If you get prompted for the next CD, then you have not copied the files over properly, or you have missed some.

6. Try turning off DMA for your CD/DVD drive. For some people, this has allowed them to install. You can find this checkbox by going to your Control Panel, then to System, then to the Device Manager tab. Find your CD/DVD drive and bring up its Properties, then go to the Settings tab.

7. Try turning off your CD/DVD read-ahead. For some people, this has allowed them to install. You can find this slider by going to your Control Panel, then to System, then to the Performance tab. Down in the Advanced Settings frame, press the File System... button and move the slider all the way to the left. You may need to restart for this setting to take effect.

If you don't know how to disable DMA and read-ahead optimisation on your CD Drive, here are the steps:

Windows 98/Me

1. Open the Control Panel
2. Open "System"
3. Choose the "Device Manager" tab
4. Click the "+" next to "CD-ROM"
5. Select your drive, right-click it and select "Properties"
6. Choose the "Settings" tab
7. Uncheck the "DMA" checkbox.
8. Click "OK" to close the Properties window
9. Choose the "Performance" tab (in the "System" control panel window, which should still be open)
10. Click the "File System" button
11. Select the "CDROM" tab
12. Select "No read-ahead" from the "Optimise access pattern for:" drop-down box

Windows 2000/XP

1. Open the Control Panel
2. Open "System"
3. Choose the "Hardware" tab
4. Click the "Device Manager" button
5. Click the "+" next to "IDE ATA/ATAPI controllers"
6. Select "Secondary IDE Channel", right click it and select "Properties"
7. Choose "PIO Only" from the drop-down box labelled "Transfer Mode"

Note: In most cases your CD-ROM or DVD Drive will be Device 0 on the Secondary IDE Channel. If you have both a DVD drive and a CD Drive, one of them may be Device 1 on the Primary IDE Channel. If you have more than one Hard Disk Drive, your CD drive could be Device 1 on the Secondary IDE Channel.

In general, you can tell a CD-ROM or DVD drive because the DMA will show up as "Ultra DMA Mode 2" or "Multi-Word DMA Mode 2" or something like that in the "Current Transfer Mode" description field.

I recommend against changing the DMA mode of Device 0 on the Primary IDE Channel. Unless your computer was built by someone who doesn't know what they're doing, this will be always be your main Hard Disk Drive.

There is no read-ahead optimisation option in Windows 2000/XP.

Title: Re: Baldur's Gate II Install Problems
Post by: Nesquaam on April 14, 2004, 10:49:29 AM
I'm now trying to install the cd's a borrowed from a classmate, hope this set works.
And thanks for the tips, but its al mathematics to me, and that says a lot ;D

BTW, the other time i tried to install, they worked perfectly, and there are no new hardware things edited to my comp.

Any ideas why ?
Title: Re: Baldur's Gate II Install Problems
Post by: Nesquaam on April 14, 2004, 03:35:02 PM
Good news al last !!!
I tried a recommende install (always do the full and crack it). And, tadadadadada (drumroll), it worked !!! :D Thanks for all your advises. Now I will lock this topic cause it has no further use.

Toodles