Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Message icon:

Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: coineineagh
« on: August 16, 2009, 01:33:37 PM »

It was as I feared: Throne of Bhaal is incomplete:(. The Grove of the Ancients doesn't exist. I haven't been able to complete the first quest in the pocket plane (AR0315) and leave the area. Cheat-jumping, and cheating in items, will be crucial if you want to do any of the remainder. I'll keep you informed.
Here's some temporary instructions for cheats to get you through Watcher's Keep:
Complete level one (AR0312) after speaking to the Knights outdoors(AR0313), because after leaving the area, the main door will remain closed. Talk with Brother Pol for the vigil stone and the incantation scroll. The Statues in the main room didn't all go hostile for me, but I couldn't damage them even when they were hostile:(. Ctrl+Y kill them to progress. In level 2 (AR0329) the Ice room has an instakill effect, and the air room has an unconsciousness and high damage effect, this makes no sense atall. You can try stuff out, but ultimately all you need in the 4 circular rooms, are _plot03A, _plot03B, _plot03C, _plot03D, _ompon12 and _blun30A. So cheat these items in with ctrlaltdelete:createitem("[itemname]"). The rest of the areas are accessible, so fight monsters, detrap, plunder, etc. Level 3 (AR0324...) hasn't even been converted for the most part. Unfortunately you must just jump to that area, collect the items there, and also cheat in: _sw1h64, _helm29, _chan20*, _sw1h68, and unfortunately the Deck of Many Things doesn't exist either :'(. You must also jump into level 4 with movetoarea("AR0335"), and be prepared for a fight. All the quests in this area seem ok, except the machine of Lum the Mad. It doesn't work atall, you can't enter a third combination, so you always get a 'punishment' effect. The demi-lich on this level can instakill you, so use disrupting weapons (Azuredge, Mace of disruption) to beat him to the punch! When jumping into level 5 (AR0343), be prepared for a fight again. Like me, you may not be able to enter the sub-areas for the Helmite ghost's challenges, but after I jumped to one of them (AR0337, 0338 and 0339), the others were accessible normally. The 'Spirit' challenge in the north doesnt work atall, so just cheat in the key _plot05C.
Demogorgon (AR0336) is tricky, since i can't seem to read the incantation scroll to imprison him. So I plot along and see what happens. Whatever you do, you can still reach that area from outside, through a tiny 'crack' in the 5th door, just like in the regular game. Good luck fighting him, i wouldn't be surprised if he just 'pops' if you use a disrupting weapon ;D! The most XP can be gained by simply killing Demogorgon, and then going outside to kill the Vigil Knights (they give you the most XP). you complete the quest this way, despite not being able to use the incantation scroll. ;)
That's where I am so far, I'll try to see which parts of Saradush can be completed soon...
Posted by: lumpy
« on: August 16, 2009, 06:43:38 AM »

I just finished iwg. It was a lot of fun.

I had that problem with killing Irenicus in hell. He had morale failure and was 'almost dead' no matter how much damage i did to him.

When i loaded game i tried again it worked fine.

I also noticed watchers keep is available, i'm gonna go there in new game with new party(with no npc, all created by me). Have you tried this quest? I wonder how hard demogorgon might be.

It's also great that game does not end after killing Irenicus. Better than in original bg2 :)
Posted by: coineineagh
« on: August 12, 2009, 03:05:05 PM »

The walkthrough ends when the writer can't seem to kill Irenicus' final form, but I had no such difficulty.
He doesn't even talk about Watcher's Keep, while I can travel there. This leads me to believe Throne of Bhaal may be playable too.
Browsing the game files in NearInfinity, I can see that the areas are there. I'm just wondering if the world map switch won't be a problem... if it is, then a list of main map codes will be necessary, as wel as frequent cheat-jumping. not a problem per se, it's how I solved BG2 megamod conflicts. But it is a lot of work. I'm still hoping that if I jump to the Grove, a new chapter will kick in, which also changes the world map.
The ToB pocket plane is working anyway, I've cheat-jumped there, and everything seems to be okay. :D
I just need to figure out how to make the transition between Suldanessellar and the Grove o/t Ancients (area where you fight Ilasera). Haven't found the area code in NearInfinity yet, so I'll be searching till I find it.

Lumpy, my guide could still take months, because I haven't completed Throne of Bhaal yet, and I'm lazy :P. But in the meantime, you can find links to my guide and all IWD2 mods on this page:
Posted by: lumpy
« on: August 08, 2009, 07:07:36 AM »

Thanks for this link,

I jumped to Havarian when Irenicus were busy casting mind blank.

That's what I love in iwg2, you always learn something :)

Let me know if you share your guide online.
Posted by: coineineagh
« on: August 08, 2009, 01:04:11 AM »

Oh, he's stuck wandering around in the room with irenicus. This is a tricky one, you'll need cheat codes:
ctrl+J jump into the room out of sight of Irenicus. Wait till Saemon walks far enough from Irenicus for you to speak with him. If Irenicus sees you, he'll call you a fool for approaching him, and everyone gets insta-killed. Reload till you get it right. Once you've spoken with Saemon, you can proceed to talk with the inmates.

This problem was described in the IWG walkthrough:
You should keep it at hand to help you workaround other problems;)
Posted by: lumpy
« on: August 07, 2009, 08:10:52 AM »

Cool, Now i have a problem :)

There's no Seamon Havarian at the Asylum when i finish Asylum tests. Without him i cant free prisoners and fight Irenicus. Any ideas?
Posted by: coineineagh
« on: August 07, 2009, 06:41:16 AM »

Hi lumpy, Bhaal never appeared inside candlekeep for me :-[, but I did figure out that the crash was caused by Bhaal's animation not being able to handle the crossbow.
But I realized that Bhall won't start firing before he speaks to you, so I figured out an original workaround: I simply edited the _PPBHAAL.DLG dialogue file to trigger the final cutscreen after the first talk with Bhaal, instead of the last. I'll be offering the edited file in my next new guide, which should be the first ever guide which also includes instructions on how to install ALL IDW2 mods including IWG2! Thanks for the advice anyway :).
Posted by: lumpy_
« on: August 06, 2009, 06:41:51 PM »

Not sure if you still need help...

I had the same problem. I just downgraded iwg to v34 and loaded game just before dream (before coming to asylum and speking to irenicus).

Game crashes when Bhaal uses crossbow, so if you fight in melee it should be ok.

Just dont go to Bhaal, go straight to imoen and Bhaal should be inside.

Hope it helps.
Posted by: coineineagh
« on: April 11, 2009, 08:10:03 AM »

 Does anyone know how I can spawn creatures?

I'm playing Icewind Gate 2, Weimer's beta conversion of Baldur's Gate 2 into the Icewind Dale 2 engine. So far all has been going swimmingly, but I'm now at the most difficult transition in the game, in terms of coding. It's a dream sequence with Imoen and Sarevok, just after Irenicus appears in Spellhold.

Basically, I need to get Sarevok to within view of Imoen, so she blurts out her line. If I talk with or attack Sarevok before that, CRASH! The walkthrough writer just advises you to keep reloading until Sarevok somehow appears inside Candlekeep instead of outside. But I don't see that happening anytime soon ::), and Sarevok won't follow me inside either.

So my plan is very simple: materialize a new Sarevok indoors, within sight of Imoen. I'm pretty sure it will work too.
But this stupid cheat console won't let me create even the lowliest of goblins; it's one command I've never gotten the hang of. Can someone help me figure out how to get the blasted create creature command to work, please? :-[

The cheat command lists all state:
Spawn given creature: ctrlaltdelete:createcreature("[creature number]")
but what exactly this 'creature number' means, I don't know ???.
After some digging in NearInfinity, I found _PPBHAAL.CRE file in the override folder. It further states in the file that the name is 'ppbhaal f4r3b8'
So far, I've tried every concievable combination of these two code names, separate, together, with spaces, underscores, you name it. All I get is the standard 'Command not found : CREATECREATURE' in reply :'(. Any help would be reeeaalllllyy welcome.