Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Message icon:

Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: cmorgan
« on: November 08, 2011, 09:39:27 PM »

What about Control Panel -> Add or Remove Programs?

Unfortunately, the age-old problem is that with some orders of uninstallation, even via Add or Remove Programs, the registry sometimes has cruft left over. The classic is uninstalling SoA before ToB, but there are others in older posts hidden in the mists of history (and EA/BioWare lack of reasonable understanding of how to archive their own older forum archives and sites, where the official posts dealing with this problem are now unattainable through regular Google searches).
Posted by: Jim Jimathy
« on: November 08, 2011, 08:21:28 PM »

You guys are awesome. That Revo program did the trick. All installed and working now. Thanks a lot!
Posted by: Ishad Nha
« on: November 08, 2011, 07:45:32 PM »

What about Control Panel -> Add or Remove Programs?
Posted by: cmorgan
« on: November 08, 2011, 05:36:30 PM »

Plainab has it right - there are manual edits you can do to the registry to let ToB know it is not really installed, but it might be better to clean it up using a registry cleaner instead of manually editing. You can check the BioWare forums; I can't remember where, but i have seen the fixes for this problem posted at most of the major communities... hold on...

Damn, I hate that BioWare/EA didn't properly archive their old stuff. My quick links are hosed.

OK, Google-Foo to the rescue:

Links to assist in the trouble follow.

should get you started.
Posted by: plainab
« on: November 08, 2011, 04:27:14 PM »

Not to sound like a infomercial or spammer but you may want to check out and try Revo uninstaller 
It can help ya to remove all the registry stuff that is making things difficult for you. 

There is a paid version as well as a free version.

Posted by: Jim Jimathy
« on: November 08, 2011, 02:25:57 PM »

Hi all! I was attempting to uninstall ToB and SoA so I could do a clean installation sans mods, and managed somehow to screw it up completely. For some reason I tried to uninstall SoA before ToB, and whilst ToB did complete the uninstallation, when I put the DVD in the drive it thinks it's still installed and will not re-install. The SoA portion of the game uninstalls and installs just fine (and is perfectly playable) but ToB is causing trouble. Everytime I run the ToB installer from the DVD (I have the 4 In 1 Boxset version, running on Windows 7) it asks if I wish to uninstall ToB, even though it already is. If I click 'Yes', it tells me immediately that ToB has been successfully uninstalled and that it will now uninstall SoA. It then announces that it cannot find SoA to uninstall it (even though that definitely is there) so the process fails. I have tried this several times with the same result.

ToB has been uninstalled, it just won't recognise that it has been. Does anyone have any ideas how to fix this petulant behaviour please? Or if that fails, how to install the thing manually from the DVD?

Thanks in advance!