Post reply

Name:
Email:
Subject:
Message icon:

Verification:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
What color is grass?:
What is the seventh word in this sentence?:
What is five minus two (use the full word)?:

shortcuts: hit alt+s to submit/post or alt+p to preview


Topic Summary

Posted by: Salk
« on: July 16, 2015, 01:03:25 AM »

I am reviving this topic because I think this is a very important piece of information.

I was experiencing this horrendous lag (East of Candlekeep and Nashkel) and the solution proposed by frago roc works perfectly.
Posted by: AnotherSchmoe
« on: September 27, 2011, 12:18:40 AM »

Ah HA! I found how to fix it (at least for myself...)  :P

Go into the baldur.ini and edit change the following lines to these values:

[Game Options]
Low Mem Sounds 1=1
Low Mem Sounds 2=1


This fixed the lag and allows the ambient sounds to work. Without the ambient sounds the game would feel empty  ;D

I LOVE YOU SO MUCH RIGHT NOW.  Like really, you don't even know.  You have my eternal gratitude sir or lady, whatever ye may be!  :D

You have just solved all of my BGTutu problems.  I was so frustrated at the ATROCIOUS framerate I was getting with ambient sounds turned on, and bummed out at the thought of playing without them that I simply WASN'T playing anymore.  I'm so happy I could tip a cow!  Thanks again.

PS:
Please forgive me for posting in an old thread (I found it with a Google search), it's probably still relevant for a lot of people though.
Posted by: frago roc
« on: December 26, 2010, 06:33:22 PM »

Ah HA! I found how to fix it (at least for myself...)  :P

Go into the baldur.ini and edit change the following lines to these values:

[Game Options]
Low Mem Sounds 1=1
Low Mem Sounds 2=1


This fixed the lag and allows the ambient sounds to work. Without the ambient sounds the game would feel empty  ;D
Posted by: SeaZephyr
« on: August 23, 2010, 09:55:53 AM »

I have this exact same problem, too, although it only seems to happen with certain mods installed.  I found out which mods I could install and which once I could not
Then it is probably not due to ambients, or is a different problem in addition. The only mods I've seen that cause choppy movement are really intensive scripting ones like SCS, BP etc.
Quote
I wonder if there is a way to force the game to access the extracted sounds Vs. the ones archived in the .BIF files.
If there are files in the override folder it will always use those instead of the same files in biffs (hence the term 'override'). It doesn't make much sense that this would improve performance (usually the opposite is true, as biffing your override prevents lag). But stranger things happen in the engine (for example, if you mod a new area that uses another area's ambients in a compressed biff, you can crash the game).

Hey, thanks for all of this information.  I do not know if it is just the ambient sounds, however, turning them off DOES work for me, completely. Its all good though, I just got used to not having them.  Oh well.  lol
Posted by: Miloch
« on: August 22, 2010, 09:53:10 PM »

I have this exact same problem, too, although it only seems to happen with certain mods installed.  I found out which mods I could install and which once I could not
Then it is probably not due to ambients, or is a different problem in addition. The only mods I've seen that cause choppy movement are really intensive scripting ones like SCS, BP etc.
Quote
I wonder if there is a way to force the game to access the extracted sounds Vs. the ones archived in the .BIF files.
If there are files in the override folder it will always use those instead of the same files in biffs (hence the term 'override'). It doesn't make much sense that this would improve performance (usually the opposite is true, as biffing your override prevents lag). But stranger things happen in the engine (for example, if you mod a new area that uses another area's ambients in a compressed biff, you can crash the game).
Posted by: SeaZephyr
« on: August 22, 2010, 05:26:17 AM »

I have this exact same problem, too, although it only seems to happen with certain mods installed.  I found out which mods I could install and which once I could not, and the number of mods that I could not install made this a truly depressing thing. 

I always first notice this during the initial cutscene  at the start of the game just outside of Candlekeep.   I used the cutscene as my tester for which mods would work and which ones would not.   If the cutscene ran smooth, the mod was ok.  If it got choppy, it was not at all ok and had to be uninstalled.  Once uninstalled, the problem went away again.   

I will try the ambient sound fix and hope it works.  I will report back if I become able to use all the mods that I found problematic.   

Edit: Turning off ambient sounds seems to have done the trick, now how does one use NearInfinity to extract the SFXSound.bif into the override folder?  I cannot seem to find an option for doing so.  It would be nice to have the sounds back.  Perhaps someone can create some sort of special tool that will do that for us automatically, in the future.   Also, I found two SFXSound.bif files, one in the "data" folder and the other in the bg1data folder.  I wonder which one is the problem file?   If I can figure out how to do it, I will just extract both into the override folder for now. 

Edit2:  Even though I couldn't seem to find the SFXSound.bif files in the Chitin.key via NearInfinity, I could find them using WinBiff made by TeamBG.   Still, extracting them into the Override folder didn't seem to help the problem.  :( I wonder if there is a way to force the game to access the extracted sounds Vs. the ones archived in the .BIF files.   

Edit3: I tried just deleting the SFXSound.bif entries from the CHITIN.KEY and found that I still had the problem, with the ambient sounds turned on.  Frustrating. 
Posted by: Valiant
« on: June 18, 2010, 03:58:45 AM »

Hi all  ;D

I had similar problems on my Tutu instalation. Some areas were unplayable due to missing or invalid ambients. All I had to do was extracting all ambient sounds from SFXSounds.biff to Override folder with NearInfinity, while still keeping empty SFXSounds.biff (or it was SFXSound.biff, canīt remmember right now) present in chittin.key. And suddenly I have all ambients in areas (you wonīt lose them) and the game run smoothly as before...

Works like a charm... ;D
Posted by: rsm
« on: August 12, 2009, 10:20:00 AM »

I'm going to hazard a guess at the Ambient sounds being the problem.

I'm now playing on a fairly large EasyTutu install, but I had similar problems years ago with other Tutu installs.  The main culprit has always been Nashkel for me.  I have no idea why, but I've always had frame rate losses and jerky movement there.  It was bad previously, but after a couple of major new mod installs it was unplayable in Nashkel.  I turned off Ambient sounds (and on 3d accel), and voila - no framerate loss.

Unfortunately for me I really like the ambient sounds.   :-\
Posted by: Macready
« on: August 11, 2008, 06:49:56 PM »

Hello -

For some reason, on my latest EasyTutu install, this problem did NOT occur. The only difference between this one and the one where the problem did occur was that I forgot to use the EasyTutu Degreenifier and switched off the 3D acceleration, (And adjusted the graphics hardware acceleration to fix the annoying Transperecy problem I am always having with IE games), and for some reason, I do no longer have slowdown problems.
* Jarin thinks that the problem lies in the Degreenifier...

You're speculating based on sparse data.  The slowdowns are the result of some sort of unfavorable interaction between the game engine and the operating environment of the machine on which it is running.

I bolded the bit of your post that is most likely to have created a difference.
Posted by: Jarin
« on: August 11, 2008, 03:10:00 AM »

For some reason, on my latest EasyTutu install, this problem did NOT occur. The only difference between this one and the one where the problem did occur was that I forgot to use the EasyTutu Degreenifier and switched off the 3D acceleration, (And adjusted the graphics hardware acceleration to fix the annoying Transperecy problem I am always having with IE games), and for some reason, I do no longer have slowdown problems.
* Jarin thinks that the problem lies in the Degreenifier...
Posted by: Amgot
« on: July 11, 2007, 08:57:16 AM »

I'm having the same problem but in BG2. So, has anyone found any solution that fix the "looping problem" while allowing to keep ambient sounds on?
Posted by: Qwallath
« on: March 12, 2006, 11:36:30 AM »

Yep, I can confirm this method works.

I had abysmal performance already in Candlekeep outside area. Inside worked perfectly, though,
but outside of Candlekeep area, it started again.

Turning off ALL ambient sounds in Config fixes the problem.

Any permanent solutions known, that allow you to keep ambient?
Posted by: Azazello
« on: November 29, 2005, 01:39:42 AM »

Dexan, thanks for this (tactical) fix! I've reinstalled TuTu and immediately got hit with this problem - again. Too bad can't have background sounds, but oh well...
Posted by: Dexan
« on: October 03, 2005, 06:31:19 AM »

Hmm, my experience on this started as soon as I left Candlekeep. Background animations ran fine, mouse pointer smooth but the characters would pause and jump to their destinations and the game became unplayable. I did'nt think it was a processor hangup. Strangly enough, when I disabled the ambient sounds ( dragged the slider to the off position in the sound menu ) the game ran as smooth as silk. Perhapse BG1TUTU is havng difficulty with the sound loops. As I said though, Candlekeep was fine and I find it interesting that people are experiencing this problem in different areas. I've tried updating my sound driver ( horrible AC97 ) but no effect. I hope this can be fixed but I will definately continue playing with TUTU.  ;)
Posted by: Ashara
« on: September 30, 2005, 09:29:49 AM »

The slow downs are not due to corrupt files, they are connected to your processing rate. TUTU is not optimized software, so it performs worst than both BG and BG2.

The areas affected are all or some of:

-Gnoll Stronghold
-All Cloakwood Forest Maps
-Wyrm's Crossing

(usually the ones that have large and complex animations, like a lot of running water)

I find that the only way I can solve the problem is by artificially dumbing down my computer in the options (I tell the game that my machine is below minimal requirements) and it turns off all the complex spell animations, shadows, graphics, sounds etc; the game looks ugly, but it runs smoothly. Once I am past the 'troubled' areas I restore the defaults. If I am too lazy to do that, I just do ExploreArea() and Ctrl+J my party around instead of painstackingly looking at them trying to walk.

Hope that helps